need access of “allowsInlineMediaPlayback”

Welcome! Forums Unity Plugins In-App Web Browser need access of “allowsInlineMediaPlayback”

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #12121
    ajay@pv
    Participant

    Hi,

    I facing problem to play video through inAppWebBrowser plugin. when i try to play the video on iphone.
    It’s started playing the video in fullscreen. I wanted to play the video inline mode not in fullscreen.
    As per this article :-“https://developer.apple.com/documentation/webkit/wkwebviewconfiguration/1614793-allowsinlinemediaplayback” allowsinlinemediaplayback is false for iphone but ipad is true.
    I think that is why video playing fine on ipad.

    It would be great, if you can guide me. How can i set this concerned flag from unity level?

    Thank you
    Ajay

    #12122
    PiotrPiotr
    Keymaster

    This value is set to true regardless of a device – are you sure you are on latest version?

    #12123
    ajay@pv
    Participant

    yes i am using latest version of the plugin.

    #12124
    ajay@pv
    Participant

    if see you cordova plugin example, in “config.xml” we can set concerned flag “allowsInlineMediaPlayback” from xml.
    here you can check. https://cordova.apache.org/docs/en/latest/reference/cordova-plugin-inappbrowser/index.html

    Thank you
    Ajay kumar

    #12129
    PiotrPiotr
    Keymaster

    As I said, it is set to true. How are you displaying video element?

    #12131
    ajay@pv
    Participant

    this is how we are displaying the video element “<video webkit-playsinline=”true” playsinline=”true” id=”my-video_html5_api” class=”vjs-tech” preload=”auto” controls>
    <source src=”https://www.w3schools.com/html/mov_bbb.mp4&#8243; type=”video/mp4″> </video>”

    • This reply was modified 1 week, 5 days ago by ajay@pv.
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.