iOS 13 issues

Welcome! Forums Unity Plugins In-App Web Browser iOS 13 issues

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • #1790

    Is anyone else having issues with iOS 13 and InAppWebBrowser? I know Apple changed a lot of things from 12 to 13, including going from a default of fullscreen to a card system, and also changing the default presentation mode.

    I have 4 iPads, two on iOS 13.1.3, one on iOS 12.4.2, and one on 12.3.1. I have the same app loaded all 4 iPads starting the example debug “ExampleScene”. On iOS 12 and iOS 13 when I tap the link Open! different behavior occurs.

    12.4.1 and 12.3.1 – Link opens correctly, expected behavior occurs.

    13.1.3 – Nothing happens. I push the button again(for a total of 2 times), I get this debug information.`SendMessage: object InAppBrowserBridge not found!
    SendMessage: object InAppBrowserBridge not found!
    2019-10-21 12:48:20.633502-0500 ExampleApp[761:390743] Warning: Attempt to present <StandardNavigationController: 0x10b1ac000> on <UnityDefaultViewController: 0x11ab6f050> which is already presenting <StandardNavigationController: 0x10a9d8a00>
    SendMessage: object InAppBrowserBridge not found!
    SendMessage: object InAppBrowserBridge not found!

    If i minimize the app, then reopen it, the app is successfully displaying It only successfully displays if I’ve tapped the button 2 different times and minimized/reopened. At this point the browser works correctly and i can push the back button to hide it, and tap the link to reopen it without minimizing the app.

    After a google search I found this

    I believe in iOS 13 they switched the property definesPresentationContext to false, which I believe may be causing the problem.

    Is anyone else able to get inappbrowser to work normally in iOS 13? I’ve tested on two different 13 devices and neither worked.


    Thanks for detailed explanations.

    1. Are you sure you are using latest version of a plugin? (2.0.1)
    2. Are you sure old files from previous versions are still inside your project (thus being exported to xcode project)?
    Those files should not be there:

    3. Are you able to reproduce it in empty project with imported plugin?


    1. Yes
    2. None of those files are there.
    3. Whoops, works on an empty project… I’m going to go look at a bunch of different settings see what’s different. If i figure it out I’ll post again.


    Interesting… that might reason why I was not able to reproduce any of these. Please let me know once you find anything!


    It appears to be related to the bug peterlaw mentioned here

    When you build without “Portrait” and “Portrait Upside Down” options inside of Unity onto a Device on iOS 13+ innAppBrowser will behave strangely like I mentioned above.

    If you build it onto iOS 12 or before, it works fine with the other options disabled.

    My app needs to be able to rotate, and have both portrait and portrait upside down disabled. Do you know of a way I could get around this? Or will this need an update?


    Did some more testing. This bug ONLY occurs if you have 3 things. 1)iOS 13. 2)Default Orientation in Unity set to “Auto Rotation”. 3)Allowed Orientation for Auto Rotation needs to have Portrait Disabled. No other options make any difference whether they are on or off.


    So I tested it on iPad with OS version 13.1.3, and Unity settings you mentioned (I think):

    Default Orientation: Auto Rotation
    Allowed orientations for Auto Rotation
    Portrait: disabled
    Portrait Upside Down: disabled
    Landscape left/right: enabled

    Opened Example scene with 2.0.1 version and… it works. Are you sure it’s about this orientation setting? Maybe something else is involved, .e.g Unity version?


    1. I upgraded Unity to the latest (2019.2.9f1). I was on 2019.2.01f previously.
    2. I created a new project.
    3. I imported 2.0.1 of in app browser.
    4. Added examplescene in build settings.
    5. Unchecked portrait mode from the auto rotation settings.
    6. Built to Xcode
    7. Signed project
    8. Built to a few devices(iPad Air 2, iPad 6th gen, iPhone 7 Plus) with 13.1.3.
    9. Opened app
    10. Same buggy behavior as before.
    I didn’t change any other settings in Unity or Xcode. If the only setting I change is checking the box next to portrait, it works perfectly. Or if I build to iOS 12 it works.

    Not sure what else to do. Gonna take a break and work on some other stuff.


    One more thought – have you tried options.shouldStickToLandscape?


    I think I found what was wrong with help from other user.

    Could you check out attached file:

    Just replace current plugin’s file inside Plugins/iOS with this one above and rebuild your xcode project.


    Hey Piotr, I realize this is a bit late, but your updated file fixed everything. I had coded kind of a janky workaround and forgot about this issue for a couple weeks. Figured I’d go ahead and check the forums again today and saw the update. Everything rotates correctly now and I don’t need portrait enabled. Thanks.


    Patch should be released on Unity Asset Store in next few days.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.